Any runs of Cloudability Datalink connectors are resulting in inaccurate reporting of Account IDs/Names at present in CT

Incident Report for IBM Apptio

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 14:24 UTC

Monitoring

A fix has been implemented and data reprocessing is in progress. Re-running the Cloud Connector and verifying in TBM studio will result in the fix.
Posted Jun 06, 2026 - 17:14 UTC

Investigating

We are currently investigating this issue.
Posted Jun 05, 2026 - 16:25 UTC
This incident affected: Americas (US) - AWS (Costing, Billing, Demand and TBM Studio, Datalink, Datalink (Classic)), Europe (EU) - AWS (Costing, Billing, Demand, and TBM Studio, Datalink, Datalink (Classic)), Australia (AU) - AWS (Costing, Billing, Demand, and TBM Studio, Datalink, Datalink (Classic)), Japan (JP) - AWS (Costing, Billing, Demand and TBM Studio, Datalink), India (IN) - AWS (Costing, Billing, Demand and TBM Studio, Datalink), Americas (US2) - Azure (Costing, Billing, Demand and TBM Studio, Datalink), Canada (CA) - AWS (Costing, Billing, Demand and TBM Studio, Datalink), and Europe (EU2) - Azure (Costing, Billing, Demand and TBM Studio, Datalink).