Apptio Planning Slowness

Incident Report for IBM Apptio

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 23:45 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 22, 2026 - 06:29 UTC

Monitoring

We have identified the source of the performance degradation and implemented corrective measures. Service performance has returned to normal levels, and we continue to monitor the environment to ensure stability.
Posted Jul 21, 2026 - 20:12 UTC

Investigating

The Apptio Planning application is currently experiencing some slowness. Our team is investigation this issue.
Posted Jul 21, 2026 - 18:47 UTC
This incident affected: Americas (US) - AWS (Planning).