US2 (Azure hosted): Microsoft Azure service degradation causing availability issues

Incident Report for Apptio One

Resolved

Microsoft Azure has resolved this issue.
Posted Oct 29, 2025 - 21:31 UTC

Update

We are continuing to investigate this issue.
Posted Oct 29, 2025 - 16:50 UTC

Investigating

Microsoft Azure is experiencing DNS issues resulting in availability issues with some products. This is impacting customers hosted in the US2 region. More details can be found on the Azure status page:
https://azure.status.microsoft/en-us/status
Posted Oct 29, 2025 - 16:49 UTC
This incident affected: Americas (US2) - Azure (Costing, Billing, Demand and TBM Studio, Planning, Apptio BI, Datalink).