Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 18, 2026 - 07:01 UTC
Scheduled
Apptio will be performing scheduled maintenance affecting TBM Studio, Costing, and Billing services. This maintenance is planned for Saturday, July 18, 2026, from 12:00 AM to 6:00 AM PDT (7:00 AM to 1:00 PM UTC) and will impact customers hosted in the Americas Azure (US2) and Europe Azure (EU2) regions. During this maintenance window, the affected services - TBM Studio, Costing, and Billing - may be partially or fully unavailable for customers in the Americas Azure (US2) and Europe Azure (EU2) regions. You may experience interruptions when attempting to access these services.
Posted Jul 16, 2026 - 14:28 UTC
This scheduled maintenance affected: Americas (US2) - Azure (Costing, Billing, Demand and TBM Studio) and Europe (EU2) - Azure (Costing, Billing, Demand and TBM Studio).