Apptio Engineering has identified a code change introduced on October 25th as the cause of this issue. That change has been rolled back, and system behavior has returned to normal.
We are continuing to investigate this incident to confirm full stability and to implement safeguards to prevent this from recurring going forward.
Posted Oct 30, 2025 - 21:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 30, 2025 - 12:52 UTC
Update
The Datalink Engineering team has identified an issue with one of the underlying APIs and is continuing to investigate further. We are observing significant delays in connector runs; however, uploads are completing successfully after some time. We will share additional updates as more information becomes available.
Posted Oct 30, 2025 - 07:27 UTC
Investigating
Apptio Engineering is actively working with the Boomi team to investigate the issue. Initial findings indicate that the impact is primarily limited to the reporting use case of the Apptio Connector. We are observing significant delays but eventually connectors able to complete the upload. We will provide further updates as soon as additional information is available from the Boomi team
Posted Oct 29, 2025 - 16:17 UTC
This incident affected: Americas (US) - AWS (Datalink), Europe (EU) - AWS (Datalink), Australia (AU) - AWS (Datalink), Middle East (ME) - AWS (Datalink), Japan (JP) - AWS (Datalink), India (IN) - AWS (Datalink), Singapore (SG) - AWS (Datalink), and Americas (US2) - Azure (Datalink).